summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html b/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
new file mode 100644
index 0000000000..3d1eaf02a2
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
@@ -0,0 +1,12 @@
+<!doctype html>
+<meta http-equiv="Content-Type" content='charset="windows-1251'>
+<meta charset=windows-1250>
+<title></title>
+<script src=/resources/testharness.js></script>
+<script src=/resources/testharnessreport.js></script>
+<link rel=help href="https://html.spec.whatwg.org/#algorithm-for-extracting-a-character-encoding-from-a-meta-element">
+<script>
+test(function() {
+ assert_equals(document.characterSet, "windows-1250");
+});
+</script>