summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html')
-rw-r--r--testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html b/testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html
new file mode 100644
index 0000000000..bfa5729371
--- /dev/null
+++ b/testing/web-platform/tests/infrastructure/assumptions/allowed-to-play.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<title>&lt;audio and &lt;video> autoplay</title>
+<link rel="help" href="https://html.spec.whatwg.org/multipage/media.html#dom-media-play">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/common/media.js"></script>
+<video></video>
+<script>
+async_test(t => {
+ const a = new Audio(getAudioURI("/media/sound_5"));
+ a.play();
+ assert_false(a.paused);
+ a.onplaying = t.step_func_done();
+}, "<audio> autoplay");
+
+async_test(t => {
+ const v = document.querySelector("video");
+ v.src = getVideoURI("/media/movie_5");
+ v.play();
+ assert_false(v.paused);
+ v.onplaying = t.step_func_done();
+}, "<video> autoplay");
+</script>