summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/infrastructure/assumptions/cookie.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/infrastructure/assumptions/cookie.html')
-rw-r--r--testing/web-platform/tests/infrastructure/assumptions/cookie.html18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/web-platform/tests/infrastructure/assumptions/cookie.html b/testing/web-platform/tests/infrastructure/assumptions/cookie.html
new file mode 100644
index 0000000000..5d5b0dc0e1
--- /dev/null
+++ b/testing/web-platform/tests/infrastructure/assumptions/cookie.html
@@ -0,0 +1,18 @@
+<!doctype html>
+<title>cookies work in default browse settings</title>
+<link rel="author" title="Intel" href="http://www.intel.com">
+<link rel="help" href="https://html.spec.whatwg.org/#dom-document-cookie">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<script>
+ test(t => {
+ t.add_cleanup(() => {
+ let date = new Date();
+ date.setTime(date.getTime() - 10000);
+ document.cookie = "name=''; expires=" + date.toGMTString();
+ });
+ document.cookie = "name=test_cookie";
+ assert_not_equals(document.cookie.match(/name=test_cookie/), null);
+ });
+</script>