summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html')
-rw-r--r--testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html b/testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html
new file mode 100644
index 0000000000..485c14d35e
--- /dev/null
+++ b/testing/web-platform/tests/quirks/body-fills-html-quirk-vertical.html
@@ -0,0 +1,23 @@
+<!DOCTYPE quirks-mode>
+<link rel="help" href="https://quirks.spec.whatwg.org/#the-body-element-fills-the-html-element-quirk"/>
+<link rel="match" href="body-fills-html-quirk-ref2.html" />
+<style>
+ html {
+ width: 200px;
+ height: 200px;
+ writing-mode: vertical-lr;
+ }
+ body {
+ border: solid;
+ margin: 10px 11px 12px 14px;
+ }
+ span {
+ display: inline-block;
+ width: 100px;
+ height: 100px;
+ background: green;
+ }
+</style>
+<body>
+ <span></span>
+</body>