summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/websockets/idlharness.any.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/websockets/idlharness.any.js')
-rw-r--r--testing/web-platform/tests/websockets/idlharness.any.js17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/web-platform/tests/websockets/idlharness.any.js b/testing/web-platform/tests/websockets/idlharness.any.js
new file mode 100644
index 0000000000..653cc36d21
--- /dev/null
+++ b/testing/web-platform/tests/websockets/idlharness.any.js
@@ -0,0 +1,17 @@
+// META: script=/resources/WebIDLParser.js
+// META: script=/resources/idlharness.js
+
+// https://websockets.spec.whatwg.org/
+
+"use strict";
+
+idl_test(
+ ['websockets'],
+ ['html', 'dom'],
+ idl_array => {
+ idl_array.add_objects({
+ WebSocket: ['new WebSocket("ws://invalid")'],
+ CloseEvent: ['new CloseEvent("close")'],
+ });
+ }
+);