summaryrefslogtreecommitdiffstats
path: root/testing/webdriver/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/webdriver/Cargo.toml')
-rw-r--r--testing/webdriver/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/webdriver/Cargo.toml b/testing/webdriver/Cargo.toml
new file mode 100644
index 0000000000..a36fb16d7e
--- /dev/null
+++ b/testing/webdriver/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+edition = "2021"
+name = "webdriver"
+version = "0.50.0"
+authors = ["Mozilla"]
+include = ["/src"]
+description = "Library implementing the wire protocol for the W3C WebDriver specification."
+documentation = "https://docs.rs/webdriver"
+readme = "README.md"
+keywords = [
+ "automation",
+ "browser",
+ "protocol",
+ "w3c",
+ "webdriver",
+]
+license = "MPL-2.0"
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/webdriver"
+
+[features]
+default = ["server"]
+server = ["tokio", "tokio-stream", "warp"]
+
+[dependencies]
+base64 = "0.21"
+bytes = "1.0"
+cookie = { version = "0.16", default-features = false }
+http = "0.2"
+icu_segmenter = { version = "1.4", default-features = false, features = ["auto", "compiled_data"] }
+log = "0.4"
+serde = "1.0"
+serde_json = "1.0"
+serde_derive = "1.0"
+time = "0.3"
+tokio = { version = "1.0", features = ["rt", "net"], optional = true}
+tokio-stream = { version = "0.1", features = ["net"], optional = true}
+url = "2.4"
+thiserror = "1"
+warp = { version = "0.3", default-features = false, optional = true }