summaryrefslogtreecommitdiffstats
path: root/third_party/rust/android_logger/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/android_logger/Cargo.toml')
-rw-r--r--third_party/rust/android_logger/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/third_party/rust/android_logger/Cargo.toml b/third_party/rust/android_logger/Cargo.toml
new file mode 100644
index 0000000000..a9fd573be2
--- /dev/null
+++ b/third_party/rust/android_logger/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "android_logger"
+version = "0.12.0"
+authors = ["The android_logger Developers"]
+description = """
+A logging implementation for `log` which hooks to android log output.
+"""
+readme = "README.md"
+keywords = [
+ "android",
+ "bindings",
+ "log",
+ "logger",
+]
+categories = ["api-bindings"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Nercury/android_logger-rs"
+
+[dependencies.android_log-sys]
+version = "0.2"
+
+[dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.once_cell]
+version = "1.9"
+
+[features]
+default = ["regex"]
+regex = ["env_logger/regex"]
+
+[badges.travis-ci]
+repository = "Nercury/android_logger-rs"