summaryrefslogtreecommitdiffstats
path: root/third_party/rust/byteorder/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/byteorder/Cargo.toml')
-rw-r--r--third_party/rust/byteorder/Cargo.toml31
1 files changed, 21 insertions, 10 deletions
diff --git a/third_party/rust/byteorder/Cargo.toml b/third_party/rust/byteorder/Cargo.toml
index c71f90ba9c..da515d9d90 100644
--- a/third_party/rust/byteorder/Cargo.toml
+++ b/third_party/rust/byteorder/Cargo.toml
@@ -3,33 +3,44 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.60"
name = "byteorder"
-version = "1.4.3"
+version = "1.5.0"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/ci/*"]
description = "Library for reading/writing numbers in big-endian and little-endian."
homepage = "https://github.com/BurntSushi/byteorder"
documentation = "https://docs.rs/byteorder"
readme = "README.md"
-keywords = ["byte", "endian", "big-endian", "little-endian", "binary"]
-categories = ["encoding", "parsing", "no-std"]
+keywords = [
+ "byte",
+ "endian",
+ "big-endian",
+ "little-endian",
+ "binary",
+]
+categories = [
+ "encoding",
+ "parsing",
+ "no-std",
+]
license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/byteorder"
+
[profile.bench]
opt-level = 3
[lib]
name = "byteorder"
bench = false
+
[dev-dependencies.quickcheck]
version = "0.9.2"
default-features = false