summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crash-context/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crash-context/Cargo.toml')
-rw-r--r--third_party/rust/crash-context/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/crash-context/Cargo.toml b/third_party/rust/crash-context/Cargo.toml
new file mode 100644
index 0000000000..add4000609
--- /dev/null
+++ b/third_party/rust/crash-context/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.59.0"
+name = "crash-context"
+version = "0.6.1"
+authors = [
+ "Embark <opensource@embark-studios.com>",
+ "Jake Shadle <jake.shadle@embark-studios.com>",
+]
+description = "Provides portable types containing target specific contextual information at the time of a crash"
+homepage = "https://github.com/EmbarkStudios/crash-handling/tree/main/crash-context"
+documentation = "https://docs.rs/crash-context"
+readme = "README.md"
+keywords = [
+ "crash",
+ "libc",
+ "getcontext",
+]
+categories = ["external-ffi-bindings"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/EmbarkStudios/crash-handling"
+resolver = "1"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.libc]
+version = "0.2"
+
+[target."cfg(target_os = \"macos\")".dependencies.mach2]
+version = "0.4"