summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-queue/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crossbeam-queue/Cargo.toml')
-rw-r--r--third_party/rust/crossbeam-queue/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-queue/Cargo.toml b/third_party/rust/crossbeam-queue/Cargo.toml
new file mode 100644
index 0000000000..2b775fbc6e
--- /dev/null
+++ b/third_party/rust/crossbeam-queue/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.38"
+name = "crossbeam-queue"
+version = "0.3.8"
+description = "Concurrent queues"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-queue"
+readme = "README.md"
+keywords = [
+ "queue",
+ "mpmc",
+ "lock-free",
+ "producer",
+ "consumer",
+]
+categories = [
+ "concurrency",
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-utils]
+version = "0.8.5"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+alloc = []
+default = ["std"]
+nightly = ["crossbeam-utils/nightly"]
+std = [
+ "alloc",
+ "crossbeam-utils/std",
+]