summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-utils/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crossbeam-utils/Cargo.toml')
-rw-r--r--third_party/rust/crossbeam-utils/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-utils/Cargo.toml b/third_party/rust/crossbeam-utils/Cargo.toml
new file mode 100644
index 0000000000..6fe3f9f955
--- /dev/null
+++ b/third_party/rust/crossbeam-utils/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.38"
+name = "crossbeam-utils"
+version = "0.8.14"
+description = "Utilities for concurrent programming"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-utils"
+readme = "README.md"
+keywords = [
+ "scoped",
+ "thread",
+ "atomic",
+ "cache",
+]
+categories = [
+ "algorithms",
+ "concurrency",
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.rustversion]
+version = "1"
+
+[features]
+default = ["std"]
+nightly = []
+std = []
+
+[target."cfg(crossbeam_loom)".dependencies.loom]
+version = "0.5"
+optional = true