summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cstr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cstr/Cargo.toml')
-rw-r--r--third_party/rust/cstr/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/cstr/Cargo.toml b/third_party/rust/cstr/Cargo.toml
new file mode 100644
index 0000000000..712f393718
--- /dev/null
+++ b/third_party/rust/cstr/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.64"
+name = "cstr"
+version = "0.2.11"
+authors = ["Xidorn Quan <me@upsuper.org>"]
+description = "Macro for building static CStr reference"
+readme = "README.md"
+keywords = [
+ "macro",
+ "cstr",
+]
+license = "MIT"
+repository = "https://github.com/upsuper/cstr"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dev-dependencies.trybuild]
+version = "1.0.30"
+
+[badges.travis-ci]
+branch = "master"
+repository = "upsuper/cstr"