summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-coreaudio/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cubeb-coreaudio/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-coreaudio/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-coreaudio/Cargo.toml b/third_party/rust/cubeb-coreaudio/Cargo.toml
new file mode 100644
index 0000000000..f9067d3c08
--- /dev/null
+++ b/third_party/rust/cubeb-coreaudio/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "cubeb-coreaudio"
+version = "0.1.0"
+authors = [
+ "Chun-Min Chang <chun.m.chang@gmail.com>",
+ "Paul Adenot <paul@paul.cx>",
+]
+readme = "README.md"
+license = "ISC"
+
+[lib]
+crate-type = [
+ "staticlib",
+ "rlib",
+]
+
+[dependencies]
+atomic = "0.4"
+audio-mixer = "0.1"
+bitflags = "2"
+cubeb-backend = "0.12.0"
+float-cmp = "0.6"
+lazy_static = "1.2"
+libc = "0.2"
+mach = "0.3"
+ringbuf = "0.2.6"
+triple_buffer = "5.0.5"
+
+[dependencies.coreaudio-sys-utils]
+path = "coreaudio-sys-utils"
+
+[dev-dependencies]
+itertools = "0.11"