summaryrefslogtreecommitdiffstats
path: root/third_party/rust/enumset/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/enumset/Cargo.toml')
-rw-r--r--third_party/rust/enumset/Cargo.toml77
1 files changed, 77 insertions, 0 deletions
diff --git a/third_party/rust/enumset/Cargo.toml b/third_party/rust/enumset/Cargo.toml
new file mode 100644
index 0000000000..7a67ada566
--- /dev/null
+++ b/third_party/rust/enumset/Cargo.toml
@@ -0,0 +1,77 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "enumset"
+version = "1.1.2"
+authors = ["Alissa Rao <lymia@lymiahugs.com>"]
+description = "A library for creating compact sets of enums."
+documentation = "https://docs.rs/enumset/"
+readme = "README.md"
+keywords = [
+ "enum",
+ "bitset",
+]
+categories = ["data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Lymia/enumset"
+resolver = "1"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.enumset_derive]
+version = "0.8.0"
+
+[dependencies.serde2]
+version = "1"
+optional = true
+default-features = false
+package = "serde"
+
+[dev-dependencies.bincode]
+version = "1"
+features = ["i128"]
+
+[dev-dependencies.rustversion]
+version = "1"
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[dev-dependencies.trybuild]
+version = "1"
+
+[features]
+alloc = []
+serde = [
+ "serde2",
+ "enumset_derive/serde",
+]
+std = [
+ "alloc",
+ "enumset_derive/proc-macro-crate",
+]
+
+[badges.maintenance]
+status = "actively-developed"
+
+[badges.travis-ci]
+branch = "master"
+repository = "Lymia/enumset"