summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gpu-alloc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gpu-alloc/Cargo.toml')
-rw-r--r--third_party/rust/gpu-alloc/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/gpu-alloc/Cargo.toml b/third_party/rust/gpu-alloc/Cargo.toml
new file mode 100644
index 0000000000..6021c6cbf2
--- /dev/null
+++ b/third_party/rust/gpu-alloc/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "gpu-alloc"
+version = "0.6.0"
+authors = ["Zakarum <zakarumych@ya.ru>"]
+description = "Implementation agnostic memory allocator for Vulkan like APIs"
+homepage = "https://github.com/zakarumych/gpu-alloc"
+documentation = "https://docs.rs/gpu-alloc-types"
+readme = "README.md"
+keywords = [
+ "gpu",
+ "vulkan",
+ "allocation",
+ "no-std",
+]
+categories = [
+ "graphics",
+ "memory-management",
+ "no-std",
+ "game-development",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/zakarumych/gpu-alloc"
+
+[dependencies.bitflags]
+version = "2.0"
+default-features = false
+
+[dependencies.gpu-alloc-types]
+version = "=0.3.0"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.tracing]
+version = "0.1.27"
+features = ["attributes"]
+optional = true
+default-features = false
+
+[features]
+default = ["std"]
+serde = [
+ "dep:serde",
+ "bitflags/serde",
+]
+std = []