summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gpu-descriptor-types/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gpu-descriptor-types/Cargo.toml')
-rw-r--r--third_party/rust/gpu-descriptor-types/Cargo.toml23
1 files changed, 14 insertions, 9 deletions
diff --git a/third_party/rust/gpu-descriptor-types/Cargo.toml b/third_party/rust/gpu-descriptor-types/Cargo.toml
index 18871bb18b..f63ba9b7b6 100644
--- a/third_party/rust/gpu-descriptor-types/Cargo.toml
+++ b/third_party/rust/gpu-descriptor-types/Cargo.toml
@@ -3,24 +3,29 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "gpu-descriptor-types"
-version = "0.1.1"
+version = "0.2.0"
authors = ["Zakarum <zakarumych@ya.ru>"]
description = "Core types of gpu-descriptor crate"
homepage = "https://github.com/zakarumych/gpu-descriptor"
-documentation = "https://docs.rs/gpu-descriptor-types/0.1.0"
-keywords = ["gpu", "vulkan", "allocation", "no-std"]
+documentation = "https://docs.rs/gpu-descriptor-types"
+keywords = [
+ "gpu",
+ "vulkan",
+ "allocation",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/zakarumych/gpu-descriptor"
+
[dependencies.bitflags]
-version = "1.2"
+version = "2.4"
default-features = false