summaryrefslogtreecommitdiffstats
path: root/third_party/rust/h2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/h2/Cargo.toml')
-rw-r--r--third_party/rust/h2/Cargo.toml128
1 files changed, 128 insertions, 0 deletions
diff --git a/third_party/rust/h2/Cargo.toml b/third_party/rust/h2/Cargo.toml
new file mode 100644
index 0000000000..e4e902950e
--- /dev/null
+++ b/third_party/rust/h2/Cargo.toml
@@ -0,0 +1,128 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63"
+name = "h2"
+version = "0.3.22"
+authors = [
+ "Carl Lerche <me@carllerche.com>",
+ "Sean McArthur <sean@seanmonstar.com>",
+]
+exclude = [
+ "fixtures/**",
+ "ci/**",
+]
+description = "An HTTP/2 client and server"
+documentation = "https://docs.rs/h2"
+readme = "README.md"
+keywords = [
+ "http",
+ "async",
+ "non-blocking",
+]
+categories = [
+ "asynchronous",
+ "web-programming",
+ "network-programming",
+]
+license = "MIT"
+repository = "https://github.com/hyperium/h2"
+
+[package.metadata.docs.rs]
+features = ["stream"]
+
+[dependencies.bytes]
+version = "1"
+
+[dependencies.fnv]
+version = "1.0.5"
+
+[dependencies.futures-core]
+version = "0.3"
+default-features = false
+
+[dependencies.futures-sink]
+version = "0.3"
+default-features = false
+
+[dependencies.futures-util]
+version = "0.3"
+default-features = false
+
+[dependencies.http]
+version = "0.2"
+
+[dependencies.indexmap]
+version = "2"
+features = ["std"]
+
+[dependencies.slab]
+version = "0.4.2"
+
+[dependencies.tokio]
+version = "1"
+features = ["io-util"]
+
+[dependencies.tokio-util]
+version = "0.7.1"
+features = [
+ "codec",
+ "io",
+]
+
+[dependencies.tracing]
+version = "0.1.35"
+features = ["std"]
+default-features = false
+
+[dev-dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.hex]
+version = "0.4.3"
+
+[dev-dependencies.quickcheck]
+version = "1.0.3"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8.4"
+
+[dev-dependencies.serde]
+version = "1.0.0"
+
+[dev-dependencies.serde_json]
+version = "1.0.0"
+
+[dev-dependencies.tokio]
+version = "1"
+features = [
+ "rt-multi-thread",
+ "macros",
+ "sync",
+ "net",
+]
+
+[dev-dependencies.tokio-rustls]
+version = "0.24"
+
+[dev-dependencies.walkdir]
+version = "2.3.2"
+
+[dev-dependencies.webpki-roots]
+version = "0.25"
+
+[features]
+stream = []
+unstable = []