summaryrefslogtreecommitdiffstats
path: root/third_party/rust/hashbrown/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/hashbrown/Cargo.toml')
-rw-r--r--third_party/rust/hashbrown/Cargo.toml40
1 files changed, 32 insertions, 8 deletions
diff --git a/third_party/rust/hashbrown/Cargo.toml b/third_party/rust/hashbrown/Cargo.toml
index fb130d24d2..0a5434e494 100644
--- a/third_party/rust/hashbrown/Cargo.toml
+++ b/third_party/rust/hashbrown/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.56.0"
+rust-version = "1.63.0"
name = "hashbrown"
-version = "0.12.3"
+version = "0.14.5"
authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
exclude = [
".github",
@@ -33,7 +33,6 @@ categories = [
]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/hashbrown"
-resolver = "2"
[package.metadata.docs.rs]
features = [
@@ -42,9 +41,10 @@ features = [
"serde",
"raw",
]
+rustdoc-args = ["--generate-link-to-definition"]
[dependencies.ahash]
-version = "0.7.0"
+version = "0.8.7"
optional = true
default-features = false
@@ -53,9 +53,11 @@ version = "1.0.0"
optional = true
package = "rustc-std-workspace-alloc"
-[dependencies.bumpalo]
-version = "3.5.0"
+[dependencies.allocator-api2]
+version = "0.2.9"
+features = ["alloc"]
optional = true
+default-features = false
[dependencies.compiler_builtins]
version = "0.1.2"
@@ -66,15 +68,30 @@ version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
+[dependencies.equivalent]
+version = "1.0"
+optional = true
+default-features = false
+
[dependencies.rayon]
version = "1.0"
optional = true
+[dependencies.rkyv]
+version = "0.7.42"
+features = ["alloc"]
+optional = true
+default-features = false
+
[dependencies.serde]
version = "1.0.25"
optional = true
default-features = false
+[dev-dependencies.bumpalo]
+version = "3.13.0"
+features = ["allocator-api2"]
+
[dev-dependencies.doc-comment]
version = "0.3.1"
@@ -91,17 +108,24 @@ features = ["small_rng"]
[dev-dependencies.rayon]
version = "1.0"
+[dev-dependencies.rkyv]
+version = "0.7.42"
+features = ["validation"]
+
[dev-dependencies.serde_test]
version = "1.0"
[features]
-ahash-compile-time-rng = ["ahash/compile-time-rng"]
default = [
"ahash",
"inline-more",
+ "allocator-api2",
]
inline-more = []
-nightly = []
+nightly = [
+ "allocator-api2?/nightly",
+ "bumpalo/allocator_api",
+]
raw = []
rustc-dep-of-std = [
"nightly",