summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jsparagus-parser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/jsparagus-parser/Cargo.toml')
-rw-r--r--third_party/rust/jsparagus-parser/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/jsparagus-parser/Cargo.toml b/third_party/rust/jsparagus-parser/Cargo.toml
new file mode 100644
index 0000000000..d1287bf6b9
--- /dev/null
+++ b/third_party/rust/jsparagus-parser/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "jsparagus-parser"
+version = "0.1.0"
+authors = ["Jason Orendorff <jason.orendorff@gmail.com>"]
+license = "MIT/Apache-2.0"
+
+[[bench]]
+name = "parser"
+harness = false
+
+[dependencies]
+arrayvec = "0.7"
+bumpalo = "3.4.0"
+
+[dependencies.jsparagus-ast]
+path = "../ast"
+
+[dependencies.jsparagus-generated-parser]
+path = "../generated_parser"
+
+[dependencies.jsparagus-json-log]
+path = "../json-log"
+
+[dev-dependencies]
+criterion = "0.3"
+
+[features]
+logging = ["jsparagus-json-log/logging"]