summaryrefslogtreecommitdiffstats
path: root/third_party/rust/khronos-egl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/khronos-egl/Cargo.toml')
-rw-r--r--third_party/rust/khronos-egl/Cargo.toml82
1 files changed, 82 insertions, 0 deletions
diff --git a/third_party/rust/khronos-egl/Cargo.toml b/third_party/rust/khronos-egl/Cargo.toml
new file mode 100644
index 0000000000..2987708252
--- /dev/null
+++ b/third_party/rust/khronos-egl/Cargo.toml
@@ -0,0 +1,82 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "khronos-egl"
+version = "6.0.0"
+authors = [
+ "Timothée Haudebourg <author@haudebourg.net>",
+ "Sean Kerr <sean@metatomic.io>",
+]
+build = "build.rs"
+description = "Rust bindings for EGL"
+documentation = "https://docs.rs/khronos-egl"
+readme = "README.md"
+keywords = [
+ "egl",
+ "gl",
+ "khronos",
+ "opengl",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/timothee-haudebourg/khronos-egl"
+
+[[example]]
+name = "wayland-static"
+required-features = ["static"]
+
+[[example]]
+name = "wayland-dynamic"
+required-features = ["dynamic"]
+
+[[example]]
+name = "load-minimal"
+required-features = [
+ "dynamic",
+ "1_4",
+]
+
+[dependencies.libc]
+version = "^0.2"
+
+[dependencies.libloading]
+version = "^0.8"
+optional = true
+
+[dev-dependencies.gl]
+version = "^0.14"
+
+[dev-dependencies.wayland-client]
+version = "^0.28"
+
+[dev-dependencies.wayland-egl]
+version = "^0.28"
+
+[dev-dependencies.wayland-protocols]
+version = "^0.28"
+features = ["client"]
+
+[build-dependencies.pkg-config]
+version = "^0.3"
+optional = true
+
+[features]
+1_0 = []
+1_1 = ["1_0"]
+1_2 = ["1_1"]
+1_3 = ["1_2"]
+1_4 = ["1_3"]
+1_5 = ["1_4"]
+default = ["1_5"]
+dynamic = ["libloading"]
+no-pkg-config = []
+static = ["pkg-config"]