summaryrefslogtreecommitdiffstats
path: root/third_party/rust/khronos-egl/shell-wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/khronos-egl/shell-wayland.nix')
-rw-r--r--third_party/rust/khronos-egl/shell-wayland.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/third_party/rust/khronos-egl/shell-wayland.nix b/third_party/rust/khronos-egl/shell-wayland.nix
new file mode 100644
index 0000000000..f681f91231
--- /dev/null
+++ b/third_party/rust/khronos-egl/shell-wayland.nix
@@ -0,0 +1,11 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+ buildInputs = [
+ pkgs.gcc
+ pkgs.libGL
+ pkgs.pkg-config
+ pkgs.wayland
+ ];
+ LD_LIBRARY_PATH="${pkgs.libGL}/lib";
+}