summaryrefslogtreecommitdiffstats
path: root/third_party/rust/libloading/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/libloading/Cargo.toml')
-rw-r--r--third_party/rust/libloading/Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/third_party/rust/libloading/Cargo.toml b/third_party/rust/libloading/Cargo.toml
index 65168d5858..d5e55487b7 100644
--- a/third_party/rust/libloading/Cargo.toml
+++ b/third_party/rust/libloading/Cargo.toml
@@ -10,9 +10,9 @@
# See Cargo.toml.orig for the original contents.
[package]
-rust-version = "1.40.0"
+rust-version = "1.56.0"
name = "libloading"
-version = "0.7.4"
+version = "0.8.3"
authors = ["Simonas Kazlauskas <libloading@kazlauskas.me>"]
description = "Bindings around the platform's dynamic library loading primitives with greatly improved memory safety."
documentation = "https://docs.rs/libloading/"
@@ -43,9 +43,9 @@ version = "1.1"
[target."cfg(unix)".dependencies.cfg-if]
version = "1"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = [
- "errhandlingapi",
- "libloaderapi",
-]
+[target."cfg(windows)".dependencies.windows-targets]
+version = ">=0.48, <0.53"
+
+[target."cfg(windows)".dev-dependencies.windows-sys]
+version = "0.52"
+features = ["Win32_Foundation"]