summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lmdb-rkv/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/lmdb-rkv/Cargo.toml')
-rw-r--r--third_party/rust/lmdb-rkv/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/lmdb-rkv/Cargo.toml b/third_party/rust/lmdb-rkv/Cargo.toml
new file mode 100644
index 0000000000..51274cf0f1
--- /dev/null
+++ b/third_party/rust/lmdb-rkv/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "lmdb-rkv"
+version = "0.14.0"
+authors = ["Dan Burkert <dan@danburkert.com>", "Victor Porof <vporof@mozilla.com>"]
+exclude = ["/.appveyor.yml", "/.travis.yml", "/azure-pipelines-template.yml", "/azure-pipelines.yml"]
+description = "Idiomatic and safe LMDB wrapper."
+homepage = "https://github.com/mozilla/lmdb-rs"
+documentation = "https://docs.rs/lmdb-rkv"
+readme = "README.md"
+keywords = ["LMDB", "database", "storage-engine", "bindings", "library"]
+categories = ["database"]
+license = "Apache-2.0"
+repository = "https://github.com/mozilla/lmdb-rs.git"
+
+[lib]
+name = "lmdb"
+[dependencies.bitflags]
+version = "1"
+
+[dependencies.byteorder]
+version = "1"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.lmdb-rkv-sys]
+version = "0.11.0"
+[dev-dependencies.rand]
+version = "0.4"
+
+[dev-dependencies.tempdir]
+version = "0.3"
+
+[features]
+default = []
+with-asan = ["lmdb-rkv-sys/with-asan"]
+with-fuzzer = ["lmdb-rkv-sys/with-fuzzer"]
+with-fuzzer-no-link = ["lmdb-rkv-sys/with-fuzzer-no-link"]
+[badges.appveyor]
+repository = "mozilla/lmdb-rs"
+
+[badges.travis-ci]
+repository = "mozilla/lmdb-rs"