summaryrefslogtreecommitdiffstats
path: root/third_party/rust/miow/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/miow/README.md')
-rw-r--r--third_party/rust/miow/README.md31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/rust/miow/README.md b/third_party/rust/miow/README.md
new file mode 100644
index 0000000000..e6cdddb227
--- /dev/null
+++ b/third_party/rust/miow/README.md
@@ -0,0 +1,31 @@
+# miow
+
+[![Build status](https://ci.appveyor.com/api/projects/status/tc5lsxokjk86949l?svg=true)](https://ci.appveyor.com/project/alexcrichton/miow)
+
+[Documentation](https://docs.rs/miow/0.3/x86_64-pc-windows-msvc/miow/)
+
+A zero overhead Windows I/O library focusing on IOCP and other async I/O
+features.
+
+```toml
+# Cargo.toml
+[dependencies]
+miow = "0.3.6"
+```
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in miow by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.