summaryrefslogtreecommitdiffstats
path: root/third_party/rust/naga/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/naga/Cargo.toml')
-rw-r--r--third_party/rust/naga/Cargo.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/third_party/rust/naga/Cargo.toml b/third_party/rust/naga/Cargo.toml
index 04375a9960..f645cc53f4 100644
--- a/third_party/rust/naga/Cargo.toml
+++ b/third_party/rust/naga/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.74"
name = "naga"
-version = "0.19.0"
+version = "0.20.0"
authors = ["gfx-rs developers"]
exclude = [
"bin/**/*",
@@ -48,11 +48,11 @@ harness = false
[dependencies]
arrayvec = "0.7"
bit-set = "0.5"
-bitflags = "2.4"
+bitflags = "2.5"
log = "0.4"
num-traits = "0.2"
rustc-hash = "1.1.0"
-thiserror = "1.0.57"
+thiserror = "1.0.59"
[dependencies.arbitrary]
version = "1.3"
@@ -79,7 +79,7 @@ version = "0.2.1"
optional = true
[dependencies.serde]
-version = "1.0.196"
+version = "1.0.198"
features = ["derive"]
optional = true
@@ -122,7 +122,6 @@ arbitrary = [
"bitflags/arbitrary",
"indexmap/arbitrary",
]
-clone = []
compact = []
default = []
deserialize = [