summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-common/Cargo.toml')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml52
1 files changed, 41 insertions, 11 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
index b04537bb0a..dc5bed385f 100644
--- a/third_party/rust/neqo-common/Cargo.toml
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -10,17 +10,22 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.70.0"
+edition = "2021"
+rust-version = "1.74.0"
name = "neqo-common"
-version = "0.7.0"
-authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+version = "0.7.2"
+authors = ["The Neqo Authors <necko@mozilla.com>"]
build = "build.rs"
+homepage = "https://github.com/mozilla/neqo/"
license = "MIT OR Apache-2.0"
+repository = "https://github.com/mozilla/neqo/"
-[dependencies]
-enum-map = "2.7"
-lazy_static = "1.4"
+[lib]
+bench = false
+
+[dependencies.enum-map]
+version = "2.7"
+default-features = false
[dependencies.env_logger]
version = "0.10"
@@ -31,20 +36,45 @@ version = "0.4"
default-features = false
[dependencies.qlog]
-git = "https://github.com/cloudflare/quiche"
-rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+version = "0.12"
+default-features = false
+
+[dependencies.quinn-udp]
+git = "https://github.com/quinn-rs/quinn/"
+rev = "a947962131aba8a6521253d03cc948b20098a2d6"
+optional = true
[dependencies.time]
-version = "0.3.23"
+version = "0.3"
features = ["formatting"]
+default-features = false
+
+[dependencies.tokio]
+version = "1"
+features = [
+ "net",
+ "time",
+ "macros",
+ "rt",
+ "rt-multi-thread",
+]
+optional = true
+default-features = false
[dev-dependencies.test-fixture]
path = "../test-fixture"
[features]
ci = []
-deny-warnings = []
+udp = [
+ "dep:quinn-udp",
+ "dep:tokio",
+]
[target."cfg(windows)".dependencies.winapi]
version = "0.3"
features = ["timeapi"]
+
+[lints.clippy.pedantic]
+level = "warn"
+priority = -1