summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-http3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-http3/Cargo.toml')
-rw-r--r--third_party/rust/neqo-http3/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/neqo-http3/Cargo.toml b/third_party/rust/neqo-http3/Cargo.toml
new file mode 100644
index 0000000000..8eeb2a58bf
--- /dev/null
+++ b/third_party/rust/neqo-http3/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.70.0"
+name = "neqo-http3"
+version = "0.7.0"
+authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+license = "MIT OR Apache-2.0"
+
+[dependencies]
+enumset = "1.1.2"
+lazy_static = "1.4"
+sfv = "0.9.3"
+smallvec = "1.11.1"
+url = "2.5"
+
+[dependencies.log]
+version = "0.4.17"
+default-features = false
+
+[dependencies.neqo-common]
+path = "./../neqo-common"
+
+[dependencies.neqo-crypto]
+path = "./../neqo-crypto"
+
+[dependencies.neqo-qpack]
+path = "./../neqo-qpack"
+
+[dependencies.neqo-transport]
+path = "./../neqo-transport"
+
+[dependencies.qlog]
+git = "https://github.com/cloudflare/quiche"
+rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[features]
+deny-warnings = []
+fuzzing = [
+ "neqo-transport/fuzzing",
+ "neqo-crypto/fuzzing",
+]