summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-http3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-http3/Cargo.toml')
-rw-r--r--third_party/rust/neqo-http3/Cargo.toml45
1 files changed, 31 insertions, 14 deletions
diff --git a/third_party/rust/neqo-http3/Cargo.toml b/third_party/rust/neqo-http3/Cargo.toml
index 8eeb2a58bf..12b9a125d0 100644
--- a/third_party/rust/neqo-http3/Cargo.toml
+++ b/third_party/rust/neqo-http3/Cargo.toml
@@ -10,22 +10,24 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.70.0"
+edition = "2021"
+rust-version = "1.74.0"
name = "neqo-http3"
-version = "0.7.0"
-authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+version = "0.7.2"
+authors = ["The Neqo Authors <necko@mozilla.com>"]
+homepage = "https://github.com/mozilla/neqo/"
license = "MIT OR Apache-2.0"
+repository = "https://github.com/mozilla/neqo/"
-[dependencies]
-enumset = "1.1.2"
-lazy_static = "1.4"
-sfv = "0.9.3"
-smallvec = "1.11.1"
-url = "2.5"
+[lib]
+bench = false
+
+[dependencies.enumset]
+version = "1.1"
+default-features = false
[dependencies.log]
-version = "0.4.17"
+version = "0.4"
default-features = false
[dependencies.neqo-common]
@@ -41,15 +43,30 @@ path = "./../neqo-qpack"
path = "./../neqo-transport"
[dependencies.qlog]
-git = "https://github.com/cloudflare/quiche"
-rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+version = "0.12"
+default-features = false
+
+[dependencies.sfv]
+version = "0.9"
+default-features = false
+
+[dependencies.smallvec]
+version = "1.11"
+default-features = false
+
+[dependencies.url]
+version = "2.5"
+default-features = false
[dev-dependencies.test-fixture]
path = "../test-fixture"
[features]
-deny-warnings = []
fuzzing = [
"neqo-transport/fuzzing",
"neqo-crypto/fuzzing",
]
+
+[lints.clippy.pedantic]
+level = "warn"
+priority = -1