summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-qpack/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-qpack/Cargo.toml')
-rw-r--r--third_party/rust/neqo-qpack/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/neqo-qpack/Cargo.toml b/third_party/rust/neqo-qpack/Cargo.toml
new file mode 100644
index 0000000000..7df63b7bf6
--- /dev/null
+++ b/third_party/rust/neqo-qpack/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.70.0"
+name = "neqo-qpack"
+version = "0.7.0"
+authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+license = "MIT OR Apache-2.0"
+
+[dependencies]
+lazy_static = "~1.4.0"
+static_assertions = "~1.1.0"
+
+[dependencies.log]
+version = "~0.4.17"
+default-features = false
+
+[dependencies.neqo-common]
+path = "./../neqo-common"
+
+[dependencies.neqo-crypto]
+path = "./../neqo-crypto"
+
+[dependencies.neqo-transport]
+path = "./../neqo-transport"
+
+[dependencies.qlog]
+git = "https://github.com/cloudflare/quiche"
+rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[features]
+deny-warnings = []