summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-qpack/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-qpack/Cargo.toml')
-rw-r--r--third_party/rust/neqo-qpack/Cargo.toml30
1 files changed, 18 insertions, 12 deletions
diff --git a/third_party/rust/neqo-qpack/Cargo.toml b/third_party/rust/neqo-qpack/Cargo.toml
index 7df63b7bf6..1becac8190 100644
--- a/third_party/rust/neqo-qpack/Cargo.toml
+++ b/third_party/rust/neqo-qpack/Cargo.toml
@@ -10,19 +10,20 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.70.0"
+edition = "2021"
+rust-version = "1.74.0"
name = "neqo-qpack"
-version = "0.7.0"
-authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+version = "0.7.2"
+authors = ["The Neqo Authors <necko@mozilla.com>"]
+homepage = "https://github.com/mozilla/neqo/"
license = "MIT OR Apache-2.0"
+repository = "https://github.com/mozilla/neqo/"
-[dependencies]
-lazy_static = "~1.4.0"
-static_assertions = "~1.1.0"
+[lib]
+bench = false
[dependencies.log]
-version = "~0.4.17"
+version = "0.4"
default-features = false
[dependencies.neqo-common]
@@ -35,11 +36,16 @@ path = "./../neqo-crypto"
path = "./../neqo-transport"
[dependencies.qlog]
-git = "https://github.com/cloudflare/quiche"
-rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+version = "0.12"
+default-features = false
+
+[dependencies.static_assertions]
+version = "1.1"
+default-features = false
[dev-dependencies.test-fixture]
path = "../test-fixture"
-[features]
-deny-warnings = []
+[lints.clippy.pedantic]
+level = "warn"
+priority = -1