summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nix/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/nix/Cargo.toml')
-rw-r--r--third_party/rust/nix/Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/third_party/rust/nix/Cargo.toml b/third_party/rust/nix/Cargo.toml
index bb04ab2702..34bc897c54 100644
--- a/third_party/rust/nix/Cargo.toml
+++ b/third_party/rust/nix/Cargo.toml
@@ -11,11 +11,12 @@
[package]
edition = "2021"
-rust-version = "1.65"
+rust-version = "1.69"
name = "nix"
-version = "0.27.1"
+version = "0.28.0"
authors = ["The nix-rust Project Developers"]
include = [
+ "build.rs",
"src/**/*",
"test/**/*",
"LICENSE",
@@ -61,11 +62,6 @@ name = "test-clearenv"
path = "test/test_clearenv.rs"
[[test]]
-name = "test-mount"
-path = "test/test_mount.rs"
-harness = false
-
-[[test]]
name = "test-prctl"
path = "test/sys/test_prctl.rs"
@@ -76,7 +72,7 @@ version = "2.3.1"
version = "1.0"
[dependencies.libc]
-version = "0.2.147"
+version = "0.2.153"
features = ["extra_traits"]
[dependencies.memoffset]
@@ -102,6 +98,9 @@ version = "1.0.7"
[dev-dependencies.tempfile]
version = "3.7.1"
+[build-dependencies.cfg_aliases]
+version = "0.1.1"
+
[features]
acct = []
aio = ["pin-utils"]
@@ -109,6 +108,7 @@ default = []
dir = ["fs"]
env = []
event = []
+fanotify = []
feature = []
fs = []
hostname = []