summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rand_chacha/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/rand_chacha/Cargo.toml')
-rw-r--r--third_party/rust/rand_chacha/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/rand_chacha/Cargo.toml b/third_party/rust/rand_chacha/Cargo.toml
new file mode 100644
index 0000000000..c907ae9742
--- /dev/null
+++ b/third_party/rust/rand_chacha/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "rand_chacha"
+version = "0.3.1"
+authors = ["The Rand Project Developers", "The Rust Project Developers", "The CryptoCorrosion Contributors"]
+description = "ChaCha random number generator\n"
+homepage = "https://rust-random.github.io/book"
+documentation = "https://docs.rs/rand_chacha"
+readme = "README.md"
+keywords = ["random", "rng", "chacha"]
+categories = ["algorithms", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-random/rand"
+[dependencies.ppv-lite86]
+version = "0.2.8"
+features = ["simd"]
+default-features = false
+
+[dependencies.rand_core]
+version = "0.6.0"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["std"]
+serde1 = ["serde"]
+simd = []
+std = ["ppv-lite86/std"]