summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ringbuf/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ringbuf/Cargo.toml')
-rw-r--r--third_party/rust/ringbuf/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/ringbuf/Cargo.toml b/third_party/rust/ringbuf/Cargo.toml
new file mode 100644
index 0000000000..416d615450
--- /dev/null
+++ b/third_party/rust/ringbuf/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "ringbuf"
+version = "0.2.8"
+authors = ["Alexey Gerasev <alexey.gerasev@gmail.com>"]
+description = "Lock-free SPSC FIFO ring buffer with direct access to inner data"
+homepage = "https://github.com/nthend/ringbuf"
+documentation = "https://docs.rs/ringbuf"
+readme = "README.md"
+keywords = ["lock-free", "spsc", "ring-buffer", "rb", "fifo"]
+categories = ["concurrency", "data-structures", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/nthend/ringbuf.git"
+resolver = "2"
+
+[[example]]
+name = "simple"
+
+[[example]]
+name = "message"
+required-features = ["std"]
+[dependencies.cache-padded]
+version = "1.2.0"
+
+[features]
+benchmark = []
+default = ["std"]
+std = []