summaryrefslogtreecommitdiffstats
path: root/third_party/rust/slab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/slab/Cargo.toml')
-rw-r--r--third_party/rust/slab/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/slab/Cargo.toml b/third_party/rust/slab/Cargo.toml
new file mode 100644
index 0000000000..8823fb823c
--- /dev/null
+++ b/third_party/rust/slab/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "slab"
+version = "0.4.8"
+authors = ["Carl Lerche <me@carllerche.com>"]
+exclude = ["/.*"]
+description = "Pre-allocated storage for a uniform data type"
+readme = "README.md"
+keywords = [
+ "slab",
+ "allocator",
+ "no_std",
+]
+categories = [
+ "memory-management",
+ "data-structures",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/tokio-rs/slab"
+
+[dependencies.serde]
+version = "1.0.95"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dev-dependencies.rustversion]
+version = "1"
+
+[dev-dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dev-dependencies.serde_test]
+version = "1"
+
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+default = ["std"]
+std = []