summaryrefslogtreecommitdiffstats
path: root/third_party/rust/socket2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/socket2/Cargo.toml')
-rw-r--r--third_party/rust/socket2/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/third_party/rust/socket2/Cargo.toml b/third_party/rust/socket2/Cargo.toml
new file mode 100644
index 0000000000..3f1578ccbd
--- /dev/null
+++ b/third_party/rust/socket2/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "socket2"
+version = "0.4.9"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Thomas de Zeeuw <thomasdezeeuw@gmail.com>",
+]
+include = [
+ "Cargo.toml",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+ "README.md",
+ "src/**/*.rs",
+]
+description = """
+Utilities for handling networking sockets with a maximal amount of configuration
+possible intended.
+"""
+homepage = "https://github.com/rust-lang/socket2"
+documentation = "https://docs.rs/socket2"
+readme = "README.md"
+keywords = [
+ "io",
+ "socket",
+ "network",
+]
+categories = [
+ "api-bindings",
+ "network-programming",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/socket2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[package.metadata.playground]
+features = ["all"]
+
+[features]
+all = []
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.139"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.9"
+features = [
+ "handleapi",
+ "ws2ipdef",
+ "ws2tcpip",
+]