summaryrefslogtreecommitdiffstats
path: root/third_party/rust/suggest/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/suggest/Cargo.toml')
-rw-r--r--third_party/rust/suggest/Cargo.toml76
1 files changed, 76 insertions, 0 deletions
diff --git a/third_party/rust/suggest/Cargo.toml b/third_party/rust/suggest/Cargo.toml
new file mode 100644
index 0000000000..17ce1af26d
--- /dev/null
+++ b/third_party/rust/suggest/Cargo.toml
@@ -0,0 +1,76 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "suggest"
+version = "0.1.0"
+exclude = [
+ "/android",
+ "/ios",
+]
+description = "Manages sponsored and web suggestions for Firefox Suggest"
+readme = "README.md"
+license = "MPL-2.0"
+
+[dependencies]
+anyhow = "1.0"
+chrono = "0.4"
+once_cell = "1.5"
+parking_lot = ">=0.11,<=0.12"
+serde_json = "1"
+thiserror = "1"
+uniffi = "0.25.2"
+
+[dependencies.error-support]
+path = "../support/error"
+
+[dependencies.interrupt-support]
+path = "../support/interrupt"
+
+[dependencies.remote_settings]
+path = "../remote_settings"
+
+[dependencies.rusqlite]
+version = "0.30.0"
+features = [
+ "functions",
+ "bundled",
+]
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dependencies.sql-support]
+path = "../support/sql"
+
+[dependencies.url]
+version = "2.1"
+features = ["serde"]
+
+[dependencies.viaduct]
+path = "../viaduct"
+
+[dev-dependencies]
+expect-test = "1.4"
+hex = "0.4"
+
+[dev-dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.rc_crypto]
+path = "../support/rc_crypto"
+
+[build-dependencies.uniffi]
+version = "0.25.2"
+features = ["build"]