summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tempfile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tempfile/Cargo.toml')
-rw-r--r--third_party/rust/tempfile/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/tempfile/Cargo.toml b/third_party/rust/tempfile/Cargo.toml
new file mode 100644
index 0000000000..4c2c2e5b66
--- /dev/null
+++ b/third_party/rust/tempfile/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63"
+name = "tempfile"
+version = "3.9.0"
+authors = [
+ "Steven Allen <steven@stebalien.com>",
+ "The Rust Project Developers",
+ "Ashley Mannix <ashleymannix@live.com.au>",
+ "Jason White <me@jasonwhite.io>",
+]
+description = "A library for managing temporary files and directories."
+homepage = "https://stebalien.com/projects/tempfile-rs/"
+documentation = "https://docs.rs/tempfile"
+readme = "README.md"
+keywords = [
+ "tempfile",
+ "tmpfile",
+ "filesystem",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Stebalien/tempfile"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.fastrand]
+version = "2.0.0"
+
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[features]
+nightly = []
+
+[target."cfg(any(unix, target_os = \"wasi\"))".dependencies.rustix]
+version = "0.38.26"
+features = ["fs"]
+
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.4"
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.52"
+features = [
+ "Win32_Storage_FileSystem",
+ "Win32_Foundation",
+]