summaryrefslogtreecommitdiffstats
path: root/third_party/rust/thiserror/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/thiserror/Cargo.toml')
-rw-r--r--third_party/rust/thiserror/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/third_party/rust/thiserror/Cargo.toml b/third_party/rust/thiserror/Cargo.toml
new file mode 100644
index 0000000000..7871761242
--- /dev/null
+++ b/third_party/rust/thiserror/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "thiserror"
+version = "1.0.56"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "derive(Error)"
+documentation = "https://docs.rs/thiserror"
+readme = "README.md"
+keywords = [
+ "error",
+ "error-handling",
+ "derive",
+]
+categories = ["rust-patterns"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/thiserror"
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[dependencies.thiserror-impl]
+version = "=1.0.56"
+
+[dev-dependencies.anyhow]
+version = "1.0.73"
+
+[dev-dependencies.ref-cast]
+version = "1.0.18"
+
+[dev-dependencies.rustversion]
+version = "1.0.13"
+
+[dev-dependencies.trybuild]
+version = "1.0.81"
+features = ["diff"]