summaryrefslogtreecommitdiffstats
path: root/third_party/rust/threadbound/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/threadbound/Cargo.toml')
-rw-r--r--third_party/rust/threadbound/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/rust/threadbound/Cargo.toml b/third_party/rust/threadbound/Cargo.toml
new file mode 100644
index 0000000000..b1a795a6f5
--- /dev/null
+++ b/third_party/rust/threadbound/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "threadbound"
+version = "0.1.5"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Make any value Sync but only available on its original thread."
+documentation = "https://docs.rs/threadbound"
+readme = "README.md"
+keywords = ["sync"]
+categories = [
+ "concurrency",
+ "rust-patterns",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/threadbound"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]