summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/uniffi_macros/Cargo.toml')
-rw-r--r--third_party/rust/uniffi_macros/Cargo.toml10
1 files changed, 7 insertions, 3 deletions
diff --git a/third_party/rust/uniffi_macros/Cargo.toml b/third_party/rust/uniffi_macros/Cargo.toml
index 9d3908ae8d..5ae193e392 100644
--- a/third_party/rust/uniffi_macros/Cargo.toml
+++ b/third_party/rust/uniffi_macros/Cargo.toml
@@ -12,11 +12,12 @@
[package]
edition = "2021"
name = "uniffi_macros"
-version = "0.25.3"
+version = "0.27.1"
authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
description = "a multi-language bindings generator for rust (convenience macros)"
homepage = "https://mozilla.github.io/uniffi-rs"
documentation = "https://mozilla.github.io/uniffi-rs"
+readme = "README.md"
keywords = [
"ffi",
"bindgen",
@@ -47,6 +48,7 @@ version = "1.0"
[dependencies.serde]
version = "1.0.136"
+features = ["derive"]
[dependencies.syn]
version = "2.0"
@@ -59,11 +61,13 @@ features = [
version = "0.5.9"
[dependencies.uniffi_build]
-version = "=0.25.3"
+version = "=0.27.1"
+optional = true
[dependencies.uniffi_meta]
-version = "=0.25.3"
+version = "=0.27.1"
[features]
default = []
nightly = []
+trybuild = ["dep:uniffi_build"]