summaryrefslogtreecommitdiffstats
path: root/third_party/rust/webrtc-sdp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/webrtc-sdp/Cargo.toml')
-rw-r--r--third_party/rust/webrtc-sdp/Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/third_party/rust/webrtc-sdp/Cargo.toml b/third_party/rust/webrtc-sdp/Cargo.toml
new file mode 100644
index 0000000000..a84ed53bb5
--- /dev/null
+++ b/third_party/rust/webrtc-sdp/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "webrtc-sdp"
+version = "0.3.11"
+authors = [
+ "Nicolas Grunbaum <na-g+github@nostrum.com>",
+ "Nils Ohlmeier <github@ohlmeier.org>",
+]
+description = "webrtc-sdp parses strings in the format of the Session Description Protocol according to RFC4566. It specifically supports the subset of features required to support WebRTC according to the JSEP draft."
+readme = "README.md"
+keywords = [
+ "webrtc",
+ "sdp",
+ "jsep",
+]
+categories = [
+ "parsing",
+ "network-programming",
+]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/webrtc-sdp"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0"
+optional = true
+
+[dependencies.url]
+version = "2.1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["enhanced_debug"]
+enhanced_debug = []
+serialize = [
+ "serde",
+ "serde_derive",
+]
+
+[badges.codecov]
+branch = "master"
+repository = "mozilla/webrtc-sdp"
+service = "github"
+
+[badges.travis-ci]
+branch = "master"
+repository = "mozilla/webrtc-sdp"