summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-core/src/lib.rs
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/wgpu-core/src/lib.rs')
-rw-r--r--third_party/rust/wgpu-core/src/lib.rs30
1 files changed, 1 insertions, 29 deletions
diff --git a/third_party/rust/wgpu-core/src/lib.rs b/third_party/rust/wgpu-core/src/lib.rs
index 9f6526fc11..5454f0d682 100644
--- a/third_party/rust/wgpu-core/src/lib.rs
+++ b/third_party/rust/wgpu-core/src/lib.rs
@@ -3,36 +3,8 @@
//! into other language-specific user-friendly libraries.
//!
//! ## Feature flags
-// NOTE: feature docs. below should be kept in sync. with `Cargo.toml`!
+#![doc = document_features::document_features!()]
//!
-//! - **`api_log_info`** --- Log all API entry points at info instead of trace level.
-//! - **`resource_log_info`** --- Log resource lifecycle management at info instead of trace level.
-//! - **`link`** _(enabled by default)_ --- Use static linking for libraries. Disable to manually
-//! link. Enabled by default.
-//! - **`renderdoc`** --- Support the Renderdoc graphics debugger:
-//! [https://renderdoc.org/](https://renderdoc.org/)
-//! - **`strict_asserts`** --- Apply run-time checks, even in release builds. These are in addition
-//! to the validation carried out at public APIs in all builds.
-//! - **`serde`** --- Enables serialization via `serde` on common wgpu types.
-//! - **`trace`** --- Enable API tracing.
-//! - **`replay`** --- Enable API replaying
-//! - **`wgsl`** --- Enable `ShaderModuleSource::Wgsl`
-//! - **`fragile-send-sync-non-atomic-wasm`** --- Implement `Send` and `Sync` on Wasm, but only if
-//! atomics are not enabled.
-//!
-//! WebGL/WebGPU objects can not be shared between threads. However, it can be useful to
-//! artificially mark them as `Send` and `Sync` anyways to make it easier to write cross-platform
-//! code. This is technically _very_ unsafe in a multithreaded environment, but on a wasm binary
-//! compiled without atomics we know we are definitely not in a multithreaded environment.
-//!
-//! ### Backends, passed through to wgpu-hal
-//!
-//! - **`metal`** --- Enable the `metal` backend.
-//! - **`vulkan`** --- Enable the `vulkan` backend.
-//! - **`gles`** --- Enable the `GLES` backend.
-//!
-//! This is used for all of GLES, OpenGL, and WebGL.
-//! - **`dx12`** --- Enable the `dx12` backend.
// When we have no backends, we end up with a lot of dead or otherwise unreachable code.
#![cfg_attr(