summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-hal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/wgpu-hal/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-hal/Cargo.toml14
1 files changed, 12 insertions, 2 deletions
diff --git a/third_party/rust/wgpu-hal/Cargo.toml b/third_party/rust/wgpu-hal/Cargo.toml
index 88f96fb59b..47195f996d 100644
--- a/third_party/rust/wgpu-hal/Cargo.toml
+++ b/third_party/rust/wgpu-hal/Cargo.toml
@@ -95,6 +95,7 @@ cfg_aliases = "0.1"
[features]
default = ["link"]
+device_lost_panic = []
dx12 = [
"naga/hlsl-out",
"d3d12",
@@ -116,12 +117,15 @@ gles = [
"glutin_wgl_sys",
"khronos-egl",
"libloading",
+ "ndk-sys",
]
+internal_error_panic = []
link = ["metal/link"]
metal = [
"naga/msl-out",
"block",
]
+oom_panic = []
renderdoc = [
"libloading",
"renderdoc-sys",
@@ -133,6 +137,7 @@ vulkan = [
"gpu-descriptor",
"libloading",
"smallvec",
+ "android_system_properties",
]
windows_rs = ["gpu-allocator"]
@@ -191,8 +196,13 @@ optional = true
[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies]
glutin = "0.29.1"
-[target."cfg(target_os = \"android\")".dependencies]
-android_system_properties = "0.1.1"
+[target."cfg(target_os = \"android\")".dependencies.android_system_properties]
+version = "0.1.1"
+optional = true
+
+[target."cfg(target_os = \"android\")".dependencies.ndk-sys]
+version = "0.5.0"
+optional = true
[target."cfg(target_os = \"emscripten\")".dependencies.khronos-egl]
version = "6"