summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/client/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/crashreporter/client/Makefile.in')
-rw-r--r--toolkit/crashreporter/client/Makefile.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/toolkit/crashreporter/client/Makefile.in b/toolkit/crashreporter/client/Makefile.in
new file mode 100644
index 0000000000..2d3ef1bee9
--- /dev/null
+++ b/toolkit/crashreporter/client/Makefile.in
@@ -0,0 +1,19 @@
+# vim:set ts=8 sw=8 sts=8 noet:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ifeq ($(OS_ARCH),WINNT)
+MOZ_WINCONSOLE = 0
+endif
+
+include $(topsrcdir)/config/rules.mk
+
+ifeq ($(OS_ARCH),Darwin)
+libs::
+ $(NSINSTALL) -D $(DIST)/bin/crashreporter.app
+ rsync -a -C --exclude '*.in' $(srcdir)/macbuild/Contents $(DIST)/bin/crashreporter.app
+ $(call py_action,preprocessor crashreporter.app/Contents/Resources/English.lproj/InfoPlist.strings,-Fsubstitution --output-encoding utf-16 -DAPP_NAME='$(MOZ_APP_DISPLAYNAME)' $(srcdir)/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in -o $(DIST)/bin/crashreporter.app/Contents/Resources/English.lproj/InfoPlist.strings)
+ $(NSINSTALL) -D $(DIST)/bin/crashreporter.app/Contents/MacOS
+ $(NSINSTALL) $(DIST)/bin/crashreporter $(DIST)/bin/crashreporter.app/Contents/MacOS
+endif