summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/mozannotation_server/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/crashreporter/mozannotation_server/Cargo.toml')
-rw-r--r--toolkit/crashreporter/mozannotation_server/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/toolkit/crashreporter/mozannotation_server/Cargo.toml b/toolkit/crashreporter/mozannotation_server/Cargo.toml
new file mode 100644
index 0000000000..747aff791e
--- /dev/null
+++ b/toolkit/crashreporter/mozannotation_server/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "mozannotation_server"
+version = "0.1.0"
+authors = ["Gabriele Svelto"]
+edition = "2018"
+license = "MPL-2.0"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+goblin = { version = "0.7", features = ["elf32", "elf64", "pe32", "pe64"] }
+memoffset = "0.8"
+mozannotation_client = { path = "../mozannotation_client/" }
+nsstring = { path = "../../../xpcom/rust/nsstring/" }
+thin-vec = { version = "0.2.7", features = ["gecko-ffi"] }
+thiserror = "1.0.38"
+
+[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies]
+libc = "0.2"
+
+[target."cfg(target_os = \"windows\")".dependencies]
+winapi = { version = "0.3", features = ["minwindef", "memoryapi", "psapi"] }
+
+[target."cfg(target_os = \"macos\")".dependencies]
+mach2 = { version = "0.4" }