summaryrefslogtreecommitdiffstats
path: root/toolkit/library/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library/rust/Cargo.toml')
-rw-r--r--toolkit/library/rust/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/toolkit/library/rust/Cargo.toml b/toolkit/library/rust/Cargo.toml
new file mode 100644
index 0000000000..b307bc8558
--- /dev/null
+++ b/toolkit/library/rust/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+name = "gkrust"
+version = "0.1.0"
+authors = ["The Mozilla Project Developers"]
+license = "MPL-2.0"
+description = "Rust code for libxul"
+
+[dependencies]
+gkrust-shared = { path = "shared" }
+mozilla-central-workspace-hack = { version = "0.1", features = ["gkrust"], optional = true }
+
+# Workarounds for https://github.com/rust-lang/rust/issues/58393
+mozglue-static = { path = "../../../mozglue/static/rust" }
+swgl = { path = "../../../gfx/wr/swgl" }
+lmdb-rkv-sys = "0.11"
+
+[dev-dependencies]
+stylo_tests = { path = "../../../servo/ports/geckolib/tests/" }
+
+[lib]
+path = "lib.rs"
+crate-type = ["staticlib"]
+test = false
+doctest = false
+bench = false
+doc = false
+plugin = false
+harness = false
+
+[package.metadata.cargo-udeps.ignore]
+normal = ["mozilla-central-workspace-hack"]