summaryrefslogtreecommitdiffstats
path: root/xpcom/rust/malloc_size_of_derive
diff options
context:
space:
mode:
Diffstat (limited to 'xpcom/rust/malloc_size_of_derive')
-rw-r--r--xpcom/rust/malloc_size_of_derive/Cargo.toml15
-rw-r--r--xpcom/rust/malloc_size_of_derive/LICENSE-APACHE201
-rw-r--r--xpcom/rust/malloc_size_of_derive/LICENSE-MIT23
-rw-r--r--xpcom/rust/malloc_size_of_derive/README.md5
-rw-r--r--xpcom/rust/malloc_size_of_derive/lib.rs143
5 files changed, 387 insertions, 0 deletions
diff --git a/xpcom/rust/malloc_size_of_derive/Cargo.toml b/xpcom/rust/malloc_size_of_derive/Cargo.toml
new file mode 100644
index 0000000000..cd37a9da1f
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "malloc_size_of_derive"
+version = "0.1.3"
+authors = ["The Servo Project Developers"]
+license = "MIT/Apache-2.0"
+description = "Crate for Firefox memory reporting, not intended for external use"
+
+[lib]
+path = "lib.rs"
+proc-macro = true
+
+[dependencies]
+proc-macro2 = "1"
+syn = { version = "2", features = ["parsing"] }
+synstructure = "0.13"
diff --git a/xpcom/rust/malloc_size_of_derive/LICENSE-APACHE b/xpcom/rust/malloc_size_of_derive/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/xpcom/rust/malloc_size_of_derive/LICENSE-MIT b/xpcom/rust/malloc_size_of_derive/LICENSE-MIT
new file mode 100644
index 0000000000..31aa79387f
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/xpcom/rust/malloc_size_of_derive/README.md b/xpcom/rust/malloc_size_of_derive/README.md
new file mode 100644
index 0000000000..5848d79be9
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/README.md
@@ -0,0 +1,5 @@
+# malloc_size_of_derive
+
+This crate is used for Firefox memory reporting. It's not intended for external
+use, but is published so that it can be used by WebRender, which can be built
+and used separately from Firefox.
diff --git a/xpcom/rust/malloc_size_of_derive/lib.rs b/xpcom/rust/malloc_size_of_derive/lib.rs
new file mode 100644
index 0000000000..9179c93391
--- /dev/null
+++ b/xpcom/rust/malloc_size_of_derive/lib.rs
@@ -0,0 +1,143 @@
+// Copyright 2016-2017 The Servo Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+//! A crate for deriving the MallocSizeOf trait.
+
+extern crate proc_macro2;
+#[macro_use]
+extern crate syn;
+#[macro_use]
+extern crate synstructure;
+
+#[cfg(not(test))]
+decl_derive!([MallocSizeOf, attributes(ignore_malloc_size_of, conditional_malloc_size_of)] => malloc_size_of_derive);
+
+fn malloc_size_of_derive(s: synstructure::Structure) -> proc_macro2::TokenStream {
+ let match_body = s.each(|binding| {
+ let mut ignore = false;
+ let mut conditional = false;
+ for attr in binding.ast().attrs.iter() {
+ match attr.meta {
+ syn::Meta::Path(ref path) | syn::Meta::List(syn::MetaList { ref path, .. }) => {
+ assert!(
+ !path.is_ident("ignore_malloc_size_of"),
+ "#[ignore_malloc_size_of] should have an explanation, \
+ e.g. #[ignore_malloc_size_of = \"because reasons\"]"
+ );
+ if path.is_ident("conditional_malloc_size_of") {
+ conditional = true;
+ }
+ }
+ syn::Meta::NameValue(syn::MetaNameValue { ref path, .. }) => {
+ if path.is_ident("ignore_malloc_size_of") {
+ ignore = true;
+ }
+ if path.is_ident("conditional_malloc_size_of") {
+ conditional = true;
+ }
+ }
+ }
+ }
+
+ assert!(
+ !ignore || !conditional,
+ "ignore_malloc_size_of and conditional_malloc_size_of are incompatible"
+ );
+
+ if ignore {
+ return None;
+ }
+
+ let path = if conditional {
+ quote! { ::malloc_size_of::MallocConditionalSizeOf::conditional_size_of }
+ } else {
+ quote! { ::malloc_size_of::MallocSizeOf::size_of }
+ };
+
+ if let syn::Type::Array(..) = binding.ast().ty {
+ Some(quote! {
+ for item in #binding.iter() {
+ sum += #path(item, ops);
+ }
+ })
+ } else {
+ Some(quote! {
+ sum += #path(#binding, ops);
+ })
+ }
+ });
+
+ let ast = s.ast();
+ let name = &ast.ident;
+ let (impl_generics, ty_generics, where_clause) = ast.generics.split_for_impl();
+ let mut where_clause = where_clause.unwrap_or(&parse_quote!(where)).clone();
+ for param in ast.generics.type_params() {
+ let ident = &param.ident;
+ where_clause
+ .predicates
+ .push(parse_quote!(#ident: ::malloc_size_of::MallocSizeOf));
+ }
+
+ let tokens = quote! {
+ impl #impl_generics ::malloc_size_of::MallocSizeOf for #name #ty_generics #where_clause {
+ #[inline]
+ #[allow(unused_variables, unused_mut, unreachable_code)]
+ fn size_of(&self, ops: &mut ::malloc_size_of::MallocSizeOfOps) -> usize {
+ let mut sum = 0;
+ match *self {
+ #match_body
+ }
+ sum
+ }
+ }
+ };
+
+ tokens
+}
+
+#[test]
+fn test_struct() {
+ let source = syn::parse_str(
+ "struct Foo<T> { bar: Bar, baz: T, #[ignore_malloc_size_of = \"\"] z: Arc<T> }",
+ )
+ .unwrap();
+ let source = synstructure::Structure::new(&source);
+
+ let expanded = malloc_size_of_derive(source).to_string();
+ let mut no_space = expanded.replace(" ", "");
+ macro_rules! match_count {
+ ($e: expr, $count: expr) => {
+ assert_eq!(
+ no_space.matches(&$e.replace(" ", "")).count(),
+ $count,
+ "counting occurences of {:?} in {:?} (whitespace-insensitive)",
+ $e,
+ expanded
+ )
+ };
+ }
+ match_count!("struct", 0);
+ match_count!("ignore_malloc_size_of", 0);
+ match_count!("impl<T> ::malloc_size_of::MallocSizeOf for Foo<T> where T: ::malloc_size_of::MallocSizeOf {", 1);
+ match_count!("sum += ::malloc_size_of::MallocSizeOf::size_of(", 2);
+
+ let source = syn::parse_str("struct Bar([Baz; 3]);").unwrap();
+ let source = synstructure::Structure::new(&source);
+ let expanded = malloc_size_of_derive(source).to_string();
+ no_space = expanded.replace(" ", "");
+ match_count!("for item in", 1);
+}
+
+#[should_panic(expected = "should have an explanation")]
+#[test]
+fn test_no_reason() {
+ let input = syn::parse_str("struct A { #[ignore_malloc_size_of] b: C }").unwrap();
+ malloc_size_of_derive(synstructure::Structure::new(&input));
+}