summaryrefslogtreecommitdiffstats
path: root/xpcom/rust/xpcom/xpcom_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'xpcom/rust/xpcom/xpcom_macros/Cargo.toml')
-rw-r--r--xpcom/rust/xpcom/xpcom_macros/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/xpcom/rust/xpcom/xpcom_macros/Cargo.toml b/xpcom/rust/xpcom/xpcom_macros/Cargo.toml
new file mode 100644
index 0000000000..78238ae6d1
--- /dev/null
+++ b/xpcom/rust/xpcom/xpcom_macros/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "xpcom_macros"
+version = "0.1.0"
+authors = ["Nika Layzell <nika@thelayzells.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+syn = { version = "2", features = ["full"] }
+quote = "1"
+proc-macro2 = "1"
+lazy_static = "1.0"
+mozbuild = "0.1"