summaryrefslogtreecommitdiffstats
path: root/keyspan_pda/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:03:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:03:39 +0000
commit64f5f3b05c4e82229c5834a40a640cbd6811f5b5 (patch)
treea56dfe853667ad38d8c8c5aa7fe81b8aff5ee326 /keyspan_pda/Makefile
parentInitial commit. (diff)
downloadfirmware-free-64f5f3b05c4e82229c5834a40a640cbd6811f5b5.tar.xz
firmware-free-64f5f3b05c4e82229c5834a40a640cbd6811f5b5.zip
Adding upstream version 20200122.upstream/20200122
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'keyspan_pda/Makefile')
-rw-r--r--keyspan_pda/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/keyspan_pda/Makefile b/keyspan_pda/Makefile
new file mode 100644
index 0000000..fc37ea4
--- /dev/null
+++ b/keyspan_pda/Makefile
@@ -0,0 +1,12 @@
+CC = gcc
+IHEX2FW = ihex2fw
+
+all: keyspan_pda.fw xircom_pgs.fw
+
+%.fw: %.S
+ $(CC) -x assembler-with-cpp -P -E -o $*.asm $<
+ as31 -l $*.asm
+ $(IHEX2FW) $*.hex $@
+
+clean:
+ rm -f *.asm *.fw *.hex *.lst *.obj