summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:09:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:09:22 +0000
commit6b4d032d4964caaa85be4ba8f3a7874afbf958cc (patch)
treea9846103274b39705a7e8be9fc28c006c18094b1 /Makefile
parentInitial commit. (diff)
downloadfirmware-nonfree-6b4d032d4964caaa85be4ba8f3a7874afbf958cc.tar.xz
firmware-nonfree-6b4d032d4964caaa85be4ba8f3a7874afbf958cc.zip
Adding upstream version 20230625.upstream/20230625upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..50a4c29
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+# This file implements the GNOME Build API:
+# http://people.gnome.org/~walters/docs/build-api.txt
+
+FIRMWAREDIR = /lib/firmware
+
+all:
+
+check:
+ @./check_whence.py
+
+install:
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh $(DESTDIR)$(FIRMWAREDIR)
+
+install-xz:
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh --xz $(DESTDIR)$(FIRMWAREDIR)
+
+install-zst:
+ install -d $(DESTDIR)$(FIRMWAREDIR)
+ ./copy-firmware.sh --zstd $(DESTDIR)$(FIRMWAREDIR)